开元棋牌没人赢过吗|开元棋牌官网app下载

當前位置:→ 股票公式指標網 > 公式解答 > 正文 

    編寫要求:

     

    www.eriei.tw網解答:

     網友求助:

    借用之前一位朋友的公式,舉個例子。

    A1:=REF(HIGH,3)=HHV(HIGH,2*3+1);
    B1:=FILTER(A1,3);
    C1:=BACKSET(B1,3+1);
    D1:=FILTER(C1,3);{高點}
    A2:=REF(LOW,3)=LLV(LOW,2*3+1);
    B2:=FILTER(A2,3);
    C2:=BACKSET(B2,3+1);
    D2:=FILTER(C2,3);{低點}
    E1:=(REF(LLV(LOW,2*3),1)+REF(HHV(HIGH,2*3),1))/2;
    E2:=(HIGH+LOW)/2;{高低點出現在同一K線上時可作取舍}
    H1:=(D1 AND NOT(D2 AND E1>=E2)) OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
    L1:=(D2 AND NOT(D1 AND E1<E2));
    H2:=D1 AND NOT(D2 AND E1>=E2);
    X1:=REF(BARSLAST(H1),1)+1;
    F1:=BACKSET(H1 AND COUNT(L1,X1)>0,LLVBARS(IF(L1,LOW,10000),X1));
    G1:=F1>REF(F1,1);
    I1:=BACKSET(G1,2);
    LD:=I1>REF(I1,1);{過濾后低點}
    L2:=LD OR ISLASTBAR OR BARSCOUNT(CLOSE)=1;
    X2:=REF(BARSLAST(L2),1)+1;
    F2:=BACKSET(L2 AND COUNT(H2,X2)>0,HHVBARS(IF(H2,HIGH,0),X2));
    G2:=F2>REF(F2,1);
    I2:=BACKSET(G2,2);
    HD:=I2>REF(I2,1);{過濾后高點}
    {
    DRAWLINE(LD,L,HD,H,0),COLORWHITE,LINETHICK1,POINTDOT;
    DRAWLINE(HD,H,LD,L,0),COLORWHITE,LINETHICK1,POINTDOT;
    }
    J1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HD),BARSLAST(LD))+1);
    J2:=J1>REF(J1,1);
    {
    DRAWLINE(J2,IF(HD,H,L),ISLASTBAR,IF(BARSLAST(HD)>BARSLAST(LD),H,L),0),
    COLORWHITE,LINETHICK1,POINTDOT;
    }


    A3:=H<REF(H,REF(BARSLAST(HD),1)+1);
    B3:=REF(H,REF(BARSLAST(HD),1)+1)>REF(H,REF(BARSLAST(HD),1)+2+REF(BARSLAST(HD),REF(BARSLAST(HD),1)+2));
    D3:=A3 AND B3 AND HD;
    E3:=BACKSET(D3,REF(BARSLAST(HD),1)+2);
    HH:=E3>REF(E3,1);{找出全部長期高點}
    A4:=L>REF(L,REF(BARSLAST(LD),1)+1);
    B4:=REF(L,REF(BARSLAST(LD),1)+1)<REF(L,REF(BARSLAST(LD),1)+2+REF(BARSLAST(LD),REF(BARSLAST(LD),1)+2));
    D4:=A4 AND B4 AND LD; E4:=BACKSET(D4,REF(BARSLAST(LD),1)+2);
    LL:=E4>REF(E4,1);{找出全部長期低點}
    DRAWICON(HH,H,10),ALIGN2; DRAWICON(LL,L,12),ALIGN1;
    H3:=HH OR ISLASTBAR OR BARSCOUNT(C)=1; {后面進行過濾,方法同前。只是不用考慮高低點出現在同一K線}
    X3:=REF(BARSLAST(H3),1)+1;
    F3:=BACKSET(H3 AND COUNT(LL,X3)>0,LLVBARS(IF(LL,L,POW(10,20)),X3));
    G3:=F3>REF(F3,1);
    I3:=BACKSET(G3,2);
    LZ:=I3>REF(I3,1),LINETHICK0; {長期低點,也可供引用}
    L4:=LZ OR ISLASTBAR OR BARSCOUNT(C)=1;
    X4:=REF(BARSLAST(L4),1)+1;
    F4:=BACKSET(L4 AND COUNT(HH,X4)>0,HHVBARS(IF(HH,H,-POW(10,20)),X4));
    G4:=F4>REF(F4,1);
    I4:=BACKSET(G4,2);
    HZ:=I4>REF(I4,1),LINETHICK0;{長期高點,也可供引用}
    DRAWLINE(HZ,H,LZ,L,0),COLORGREEN,LINETHICK1;
    DRAWLINE(LZ,L,HZ,H,0),COLORGREEN,LINETHICK1;{長期連線}
    K1:=BACKSET(ISLASTBAR,MIN(BARSLAST(HZ),BARSLAST(LZ))+1); K2:=K1>REF(K1,1);
    DRAWLINE(K2,IF(HZ,H,L),ISLASTBAR,C,0),COLORGREEN,LINETHICK2; {最后的長期連線,連在收盤價上}

    選第一低點:=BACKSET(ISLASTBAR,BARSLAST(lz)+1);
    第一低點:=選第一低點>REF(選第一低點,1);
    選第二低點:=BACKSET(選第一低點,REF(BARSLAST(lz),1)+2);
    第二低點:=選第二低點>REF(選第二低點,1);

    選第一高點:=BACKSET(ISLASTBAR,BARSLAST(hz)+1);
    第一高點:=選第一高點>REF(選第一高點,1);
    ----------------------------------------------------------

    接下來的思路是這樣
    第一種情況下:
    如果 大波段的倒數的第一個低點,在大波段的倒數第一個高點之后才出現,
    那么就定位在大波段的倒數第二個低點上,
    就做這兩個點(第二低點,第一高點)的趨勢線。

    第二種情況下
    如果 大波段的倒數的第一個低點,在大波段的倒數第一個高點之前就出現了,沒有后續的大波段低點了,
    那么就在這個第一個低點定位。

    就做這兩個點(第一低點,第一高點)的趨勢線。

    這兩個條件是同時成立的。
    畫出來是圖上是只有一條向右上方延長的線出現。。。
     

    低點中兩選一,在加一個高點,劃出趨勢線

    低點中兩選一,在加一個高點,劃出趨勢線

    解答如下:
    j3:=sum(hz,0);
    j4:=sum(lz,0);
    j5:=j3[datacount]-j3+1;
    j6:=j4[datacount]-j4+1;
    j7:=barslast(hz);
    j8:=barslast(lz);
    j9:=j7[datacount];
    j10:=j8[datacount];
    drawline(lz and j6=2 and j9>j10,l,hz and j5=1,h,1)coloryellow;
    drawline(lz and j6=1 and j9<j10,l,hz and j5=1,h,1)coloryellow;

    低點中兩選一,在加一個高點,劃出趨勢線

    低點中兩選一,在加一個高點,劃出趨勢線

     

    互動內容:
    昵稱: 驗證碼:驗證碼 

關于我們 - 聯系我們 - 廣告合作 - 下載聲明 - 網站幫助 - 友情鏈接 - 網站地圖 - RSS訂閱 - TOP
Copyright © 銘網科技,All Rights Reserved. 湘ICP備09016573號-3
股票公式,股票指標,股票軟件,股票知識
股票公式,股票指標,股票軟件,股票知識湘公網安備43108102000039號

开元棋牌没人赢过吗 股票融资融券成本 炒股亏损 生不如死 股票融资软件ˉ杨方配资开户 短线炒股就这几招 全球股票指数行情东方财富网 股票涨跌值表示什么 a股大盘上证指数 股票配资排名 丨找杨方配资开户 股票配资排名·选杨方配资 股票行情